slime causes error in Mac OS X emacs23.1.1-nox

Discussion of programming Lisps using Emacs, including SLIME and other tools

slime causes error in Mac OS X emacs23.1.1-nox

Postby jreeseUE » Thu Jul 28, 2011 7:55 am

Hello, I am running Mac OS X 10.6.8 with Emacs 23.1.1-nox and am trying to get slime running within my Emacs. I've installed slime (at least I believe I have) appropriately in "~/.emacs.d/slime/" and added the appropriate lines to my .emacs file as per the Emacs site's instructions:
Code: Select all
(setq inferior-lisp-program "/usr/local/lib/sbcl/") ; your Lisp system
(add-to-list 'load-path "~/.emacs.d/slime/")  ; your SLIME directory
(require 'slime)
(slime-setup


However, when I do M-x slime in from Emacs I get the error: "Specified program for new process is a directory". I'm not sure what this means and extensive googling hasn't produced any solid results yet. Any help out there would be most appreciated. Thanks.
jreeseUE
 
Posts: 5
Joined: Thu Jul 28, 2011 7:47 am

Re: slime causes error in Mac OS X emacs23.1.1-nox

Postby Ramarren » Thu Jul 28, 2011 10:22 am

The inferior-lisp-program must contain a path of the program executable. In your snippet it is a directory, like the error message states. And it is the directory of the support files, not the executable, which should be either under some bin hierarchy, or wherever you installed the implementation.
Ramarren
 
Posts: 613
Joined: Sun Jun 29, 2008 4:02 am
Location: Warsaw, Poland

Re: slime causes error in Mac OS X emacs23.1.1-nox

Postby jreeseUE » Thu Jul 28, 2011 8:44 pm

Very good! Thanks for your reply. That line was wrong...as I misinterpreted it. Changed to:

Code: Select all
(setq inferior-lisp-program "/opt/local/bin/sbcl") ; your Lisp system



Thanks again!.
jreeseUE
 
Posts: 5
Joined: Thu Jul 28, 2011 7:47 am


Return to Emacs

Who is online

Users browsing this forum: No registered users and 0 guests

cron