Failing to asdf-install cl-yacc in Windows

Discussion of Common Lisp

Failing to asdf-install cl-yacc in Windows

Postby yena » Sat Jun 28, 2008 5:01 pm

I have an application using cl-yacc that works fine on Linux, but when I try to install cl-yacc in Windows (sbcl) I get errors. I use:
Code: Select all
  (require 'asdf)
  (require 'asdf-install)
  (asdf-install:install 'cl-yacc)

First I got an error that tar failed. I installed GNU tar, and added it to PATH. Now the system managed to download and unpack the package, but I get an error from asdf-install (non-empty buffer when EOF reached while reading from child...) and nothing appears in the site folder. How can I get this to work, preferably without having to install cygwin?
yena
 
Posts: 12
Joined: Sat Jun 28, 2008 2:33 am

Re: Failing to asdf-install cl-yacc in Windows

Postby wm.annis » Sat Jun 28, 2008 5:52 pm

The web site where cl-yacc lives has been missing for at least two days.
ἀραχναῖος ὗς ἀραχναῖος ὗς —
πράττει ἄττ’ ἂν πράττῃ ἀραχναῖός τις ὗς..
wm.annis
 
Posts: 7
Joined: Sat Jun 28, 2008 6:01 am

Re: Failing to asdf-install cl-yacc in Windows

Postby yena » Sat Jun 28, 2008 6:56 pm

wm.annis wrote:The web site where cl-yacc lives has been missing for at least two days.

It worked last Thursday when I tried it, so the problem is not the download, but something goes wrong during the compilation/installation. Just wondered if this is a known issue, and if I'm doing anything obviously wrong. I'm trying to avoid Windows, but sometimes the customers are unwilling to see reason ;)
yena
 
Posts: 12
Joined: Sat Jun 28, 2008 2:33 am

Re: Failing to asdf-install cl-yacc in Windows

Postby Flatlander » Sat Jun 28, 2008 11:41 pm

You could always install the library manually. Or if it has lots of dependancies copy the whole systems directory from Linux (just be sure to remove the .fasls first)
Flatlander
 
Posts: 8
Joined: Sat Jun 28, 2008 12:06 pm
Location: Finland

Re: Failing to asdf-install cl-yacc in Windows

Postby mmmk » Sun Jun 29, 2008 9:25 am

wm.annis wrote:The web site where cl-yacc lives has been missing for at least two days.


IMO, this is one of the big flaws in the ASDF-Install way of doing things (ie. dependency on the author's hosting choices).
mmmk
 
Posts: 8
Joined: Sat Jun 28, 2008 11:37 pm

Re: Failing to asdf-install cl-yacc in Windows

Postby gwking » Mon Jun 30, 2008 8:11 am

Hi,

It looks like a (the) problem is that the cl-yacc system has its definition in the file yacc.asd. ASDF (and ASDF-Install) both assume (and, in fact, demand) that the system file have the same name as the system. I don't know if cl-yacc is maintained; if not, I'll put up a mirror with the correct system name. I've got to run right now but I'll try to track this down later today.
gwking
 
Posts: 2
Joined: Mon Jun 30, 2008 7:47 am


Return to Common Lisp

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests

cron