Hunchentoot loading error

You have problems, and we're glad to hear them. Explain the problem, what you have tried, and where you got stuck.
Feel free to share a little info on yourself and the course.
Forum rules
Please respect your teacher's guidelines. Homework is a learning tool. If we just post answers, we aren't actually helping. When you post questions, be sure to show what you have tried or what you don't understand.

Hunchentoot loading error

Postby damienb » Thu Jan 02, 2014 1:54 am

Hi all,

Please bear with me, I'm a noob.

I'm running SBCL through Gvim/Slimv on Windows 7.

When the laughter at my OS dies down, continue:

I'm attempting to get through this tutorial: http://www.adampetersen.se/articles/lispweb.htm

I've gotten quicklisp installed (how exactly, I've forgotten) and when I type:

Code: Select all
>> (ql:quickload :hunchentoot)


I get the error:

error opening #P"C:/Windows/C/quicklisp/dists/quicklisp/software/cffi_0.11.2/tests/compile.bat"

I know there's probably something fundamental I don't get yet here, such as how packages work, how quicklisp works, where/if I should have Hunchentoot on my hard drive, how/if I need to use ASDF (?), and so on, but I have yet to find much in the way of "ground-up" lisp tutorials out there, at least when it comes to writing real software that does real things. I'm not even sure which questions to ask.

Any help/resources/"duh" clarifications would be appreciated.

I'm logging off and will plan to dig into Chapter 21 of Practical Common Lisp as some bedtime reading, so maybe I'll have a better handle on things when I log in next.

Thanks!

Damien
damienb
 
Posts: 3
Joined: Thu Jan 02, 2014 1:45 am

Re: Hunchentoot loading error

Postby nuntius » Thu Jan 02, 2014 1:30 pm

Hi Damien,

This looks like a possible CFFI problem on Win7. You appear to be running the latest CFFI. What version of SBCL are you using?

You will probably get the best help by sending this problem report to the CFFI mailing list. To join the CFFI mailing list, send an email to cffi-devel+subscribe@common-lisp.net. Then you should get an activation email, after which you should be able to send messages.
User avatar
nuntius
 
Posts: 498
Joined: Sat Aug 09, 2008 10:44 am
Location: Burlington, MA

Re: Hunchentoot loading error

Postby damienb » Thu Jan 02, 2014 2:16 pm

The top of my REPL says:
SBCL 1.1.12 Port: 4005 Pid: 976

I don't remember installing CFFI and it's not a dependency for Hunchentoot, according to http://weitz.de/hunchentoot/#install .

C:\Windows\C is not a directory, though C:\quicklisp\dists\quicklisp\software is. In that folder, though, there is no cffi_anything folder. What/who is trying to open that folder and why?

I tried
Code: Select all
(asdf:load-system :hunchentoot)


and it said Component :HUNCHENTOOT not found. I'm still not entirely clear on what asdf does vs. what quicklisp does, and how/if they overlap.
damienb
 
Posts: 3
Joined: Thu Jan 02, 2014 1:45 am

Re: Hunchentoot loading error

Postby damienb » Thu Jan 02, 2014 2:28 pm

Interestingly, there doesn't seem to be an immediate problem in LispWorks. Since I'm using the Personal Edition (no init file), I type:

Code: Select all
(load "C:\\quicklisp\\setup.lisp")

then
Code: Select all
(ql:quickload :hunchentoot)


And the only error I get at the end says:
The following function is undefined:
TRIVIAL-BACKTRACE::IMPL-MAP-BACKTRACE which is referenced by TRIVIAL-BACKTRACE:MAP-BACKTRACE


So, perhaps it's a SBCL-specific problem? I'm really clueless here.
damienb
 
Posts: 3
Joined: Thu Jan 02, 2014 1:45 am


Return to Homework

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest