problem installing lisp in box

Discussion of Common Lisp

problem installing lisp in box

Postby phillip1882 » Sun Apr 26, 2009 6:02 am

when i try to install lisp in box, i get the following
after doing ./setup, make, make install,
Code: Select all
(cd emacs-21.3; make install)
make[1]: Entering directory `/home/phillip/lispbox/emacs-21.3'
if [ ! -f /home/phillip/lispbox/emacs-21.3/lisp/abbrev.elc ]; then \
     make -w bootstrap; \
   fi
cd lib-src; make all -w \
     CC='gcc' CFLAGS='-g -O2' CPPFLAGS='-D_BSD_SOURCE  ' \
     LDFLAGS='' MAKE='make'
make[2]: Entering directory `/home/phillip/lispbox/emacs-21.3/lib-src'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/phillip/lispbox/emacs-21.3/lib-src'
cd src; make all -w \
     CC='gcc' CFLAGS='-g -O2' CPPFLAGS='-D_BSD_SOURCE  ' \
     LDFLAGS='' MAKE='make'
make[2]: Entering directory `/home/phillip/lispbox/emacs-21.3/src'
cd ../lwlib/; make -w CC='gcc' CFLAGS='-g -O2' MAKE='make' "C_SWITCH_X_SITE=" "C_SWITCH_X_MACHINE=" "C_SWITCH_X_SYSTEM=" "C_SWITCH_SITE=" "C_SWITCH_MACHINE=" "C_SWITCH_SYSTEM=-D_BSD_SOURCE"
make[3]: Entering directory `/home/phillip/lispbox/emacs-21.3/lwlib'
gcc -c -DUSE_LUCID  -D_BSD_SOURCE    -D_BSD_SOURCE   -g -O2 -DEMACS_BITMAP_FILES -DHAVE_CONFIG_H -Demacs -I. -I../src -I/home/phillip/lispbox/emacs-21.3/lwlib -I/home/phillip/lispbox/emacs-21.3/lwlib/../src /home/phillip/lispbox/emacs-21.3/lwlib/lwlib.c
/home/phillip/lispbox/emacs-21.3/lwlib/lwlib.c:52:27: error: X11/Xaw/Paned.h: No such file or directory
make[3]: *** [lwlib.o] Error 1
make[3]: Leaving directory `/home/phillip/lispbox/emacs-21.3/lwlib'
make[2]: *** [really-lwlib] Error 2
make[2]: Leaving directory `/home/phillip/lispbox/emacs-21.3/src'
make[1]: *** [src] Error 2
make[1]: Leaving directory `/home/phillip/lispbox/emacs-21.3'
make: *** [install] Error 2

how do i fix this?
phillip1882
 

Re: problem installing lisp in box

Postby gugamilare » Mon Apr 27, 2009 4:33 pm

Did you install all build dependencies for emacs? In Ubuntu you would do this by calling

Code: Select all
sudo apt-get build-dep emacs


otherwise you probably need to install the development packages of everything needed by hand.
gugamilare
 
Posts: 406
Joined: Sat Mar 07, 2009 6:17 pm
Location: Brazil


Return to Common Lisp

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests

cron