Page 1 of 1

Hunchentoot installation questions... [solved]

PostPosted: Tue Feb 14, 2012 5:39 pm
by roboticist
OK, I used quicklisp to install hunchentoot, and everything seems successful except that it doesn't seem to work. Can somebody suggest where I should go next?

# cat /etc/debian_version
6.0.4

* (asdf:oos 'asdf:load-op :hunchentoot-test)
debugger invoked on a ASDF:MISSING-DEPENDENCY in thread #<THREAD
"initial thread" RUNNING
{AAE5809}>:
component :DRAKMA not found, required by #<SYSTEM "hunchentoot-test">

Type HELP for debugger help, or (SB-EXT:QUIT) to exit from SBCL.

restarts (invokable by number or by possibly-abbreviated name):
0: [RETRY]

debugger invoked on a SIMPLE-ERROR in thread #<THREAD "initial thread" RUNNING
{AAE5809}>:
There is no applicable method for the generic function
#<STANDARD-GENERIC-FUNCTION ASDF:COMPONENT-NAME (1)>
when called with arguments
(:DRAKMA).

Type HELP for debugger help, or (SB-EXT:QUIT) to exit from SBCL.

restarts (invokable by number or by possibly-abbreviated name):
0: [RETRY] Retry calling the generic function.
1: [ABORT] Exit debugger, returning to top level.

(ASDF::%DO-ONE-DEP
#<ASDF:COMPILE-OP NIL {C66CE59}>
#<ASDF:SYSTEM "hunchentoot-test">
#<CLOSURE (FLET ASDF::COLLECT) {BBD1FED}>
ASDF:COMPILE-OP
:DRAKMA
NIL)
0]

These are the dependencies and packages loaded by quicklisp. drakma does not seem to be there. My instructions may be out of date, but it seems that all of the instructions are out of date.
; Loading "hunchentoot"
..................................................
[package alexandria.0.dev]........................
[package bordeaux-threads]........................
[package split-sequence]..........................
[package usocket].................................
[package trivial-backtrace].......................
[package rfc2388].................................
[package md5].....................................
[package trivial-garbage].........................
[package trivial-gray-streams]....................
[package flexi-streams]...........................
..................................................
..................................................
[package babel-encodings].........................
[package babel]...................................
[package cffi-sys]................................
[package cffi]....................................
[package cffi-features]...........................
[package cl+ssl]..................................
[package cl-ppcre]................................
..................................................
[package cl-fad]..................................
[package cl-fad-test].............................
[package cl-base64]...............................
[package chunga]..................................
[package url-rewrite].............................
[package hunchentoot]...........................
("hunchentoot")

I couldn't find hunchentoot in the expected directory:
(/usr/share/common-lisp/source/cl-hunchentoot
/usr/share/doc/cl-hunchentoot)

or systems in:

/usr/share/common-lisp/systems/hunchentoot-test.asd
/usr/share/common-lisp/systems/hunchentoot.asd

so I did my updatedb and tried find. It doesn't look like it actually installed.

root@bostrom:~# find / -name *hunchentoot* -print &
[1] 1159
root@bostrom:~# /root/quicklisp/dists/quicklisp/software/hunchentoot-1.2.2
/root/quicklisp/dists/quicklisp/software/hunchentoot-1.2.2/doc/hunchentoot.gif
/root/quicklisp/dists/quicklisp/software/hunchentoot-1.2.2/hunchentoot.asd
/root/quicklisp/dists/quicklisp/software/hunchentoot-1.2.2/www/hunchentoot.gif
/root/quicklisp/dists/quicklisp/software/hunchentoot-1.2.2/www/hunchentoot-doc.html
/root/quicklisp/dists/quicklisp/archives/hunchentoot-1.2.2.tgz
/root/quicklisp/dists/quicklisp/installed/systems/hunchentoot.txt
/root/quicklisp/dists/quicklisp/installed/releases/hunchentoot.txt
/root/.cache/common-lisp/sbcl-1.0.40.0.debian-linux-x86/root/quicklisp/dists/quicklisp/software/hunchentoot-1.2.2

[1]+ Done find / -name *hunchentoot* -print

I presume I crossed directions somewhere and I could use some advice.

Thanks,

Mike

Re: Hunchentoot installation questions...

PostPosted: Tue Feb 14, 2012 10:36 pm
by Ramarren
Quicklisp resolves dependencies for installation by systems. You used quicklisp to install hunchentoot system, but not hunchentoot-test, which has additional dependencies required for testing.

It seems installed under /root/quicklisp/dists/quicklisp/software/hunchentoot-1.2.2/ . This looks as if you are running your Lisp as the administrator, which is probably not really a good idea.

Up to date documentation is always on the Hunchentoot webpage. I don't know if there are current tutorials, since Hunchentoot has been significantly changed some time ago, and I don't really use it, but enough time has passed that there should be.

Re: Hunchentoot installation questions...

PostPosted: Wed Feb 15, 2012 2:10 am
by Kompottkin
In addition, note that you don't need to use asdf:oos at all. (ql:quickload :hunchentoot-test) should always work fine (and is easier to type, too), regardless of whether the system in question has already been downloaded or not. It's magic! :)

Re: Hunchentoot installation questions...

PostPosted: Thu Feb 16, 2012 9:12 am
by roboticist
Thank you. It has been many years since I've used LISP and I'm still catching up. The hutchentoot web page seems a little out-of-date, but it may just mean that current LISP users are taking for granted things I ought to know.

Is it possible to mark this topic as "Solved" somehow?

Re: Hunchentoot installation questions... [solved]

PostPosted: Thu Feb 16, 2012 4:36 pm
by nuntius
Never done it before, but I just edited your original post so the subject would say "solved".

Roboticist, as original author, can you do the same? (I'm curious)