macroexpand-1 and pretty-printing in SLIME

Discussion of programming Lisps using Emacs, including SLIME and other tools

macroexpand-1 and pretty-printing in SLIME

Postby JohnGraham » Sun Nov 14, 2010 1:53 pm

Hi there. I can't seem to get pretty-printing to work in slime or "regular" lisp. I try just doing (macroepand-1 '(macro etc.)) at the REPL, as well as C-c RET at an expression I want to see expanded, but it always prints the macro expansion on a single line. I checked *print-pretty* and it's set to t. Anyone know what else I need to change to get macros to print out more legibly?

I'm using SBCL and emacs 22.2.1 with slime-2009-11-05, if they make any difference...
JohnGraham
 
Posts: 4
Joined: Thu Nov 05, 2009 2:54 pm

Re: macroexpand-1 and pretty-printing in SLIME

Postby Ramarren » Sun Nov 14, 2010 3:02 pm

JohnGraham wrote:I'm using SBCL and emacs 22.2.1 with slime-2009-11-05, if they make any difference...


Well, that version is obviously a year old, so perhaps updating to a current version would help. On my system pretty printing just happens. I initialize slime with (possibly redundant):
Code: Select all
(slime-setup '(slime-fancy slime-autodoc slime-asdf slime-banner slime-indentation))
Ramarren
 
Posts: 613
Joined: Sun Jun 29, 2008 4:02 am
Location: Warsaw, Poland

Re: macroexpand-1 and pretty-printing in SLIME

Postby JohnGraham » Sun Nov 14, 2010 4:14 pm

Ramarren wrote: I initialize slime with (possibly redundant):
Code: Select all
(slime-setup '(slime-fancy slime-autodoc slime-asdf slime-banner slime-indentation))


That seems to have done the trick - I was just using (slime-setup). Much nicer now. Cheers!
JohnGraham
 
Posts: 4
Joined: Thu Nov 05, 2009 2:54 pm


Return to Emacs

Who is online

Users browsing this forum: No registered users and 2 guests